• Tradewars under linux

    From Dumas Walker@1:2320/105 to ALL on Saturday, September 23, 2017 07:48:00
    For months now, I have been struggling with getting Tradewars working again under linux. It was working but, sometime back in June, the EXTERN program began crashing my DOS maintenance BAT. By "crashing," I mean it was
    closing the dosemu window entirely, without a visible error message.

    I tried running EXTERN under dosbox, as well as BIGBANG, and get the
    following error:

    File Error (1) - (filename).DAT : Invalid Function

    filename = the name of the DAT file that the programs are presumably
    attempting to access at that moment (it varies, depending on the program
    and function).

    I thought that upgrading to the latest version of debian caused this, as
    that version of dosemu did cause other issues with other programs. I downgraded dosemu to the previous working version and, although all the
    other BBS issues went away, the TW issue is still happening.

    I do not remember doing anything special to the dosemu settings to get this running... did any of you all that have tradewars working?

    Some other things I tried... I went back to the OS/2 box I migrated the BBS from, and the EXTERN program runs fine there. I copied all of those files - DAT, EXE, and the whole directory structure - from the OS/2 box to the
    linux box and the problem immediately returned, as in first time I ran

    As stated, I tried BIGBANG-ing the universe over again, and that program crashes, too. I have NOT yet tried a fresh install... I need to locate my registration info before I do that.

    I even tried copying a fresh-from-OS/2-install copy over to a DOS-formatted device (thinking maybe I was running into an upper/lower case issue),
    mounting that device to linux, and running TW from there. Same issue.

    Tradewars was the one door I liked playing myself, so I would like to get
    it running again. Thanks for any assistance.


    P.S. FWIW, I am running TW under a DOS BBS that is also running in dosemu,
    the same one it ran under when it was on the OS/2 box, and not under SBBS or Mystic. However, any input may still be relevant. :)

    . SLMR 2.1a . Does anybody here remember Vera Lynn?
    --- SBBSecho 2.12-Linux
    * Origin: CCO BBS - capcity2.synchro.net - 1-502-875-8938 (1:2320/105)