• Errors with syncTerm downloads and Mystic BBS

    From hal@21:1/177 to All on Friday, February 19, 2021 15:24:53
    Hi all I have setup a small BBS and got it up and running.


    Access via netrunner works seamlessly and uploads and downloads work
    perfectly.

    However, I have also tried syncterm and found that when I download using
    zmodem I get the following error

    !ERROR zmodem_recv_hex_error_init received Invalid Header not terminated with LF

    I assume this is because I am running this on a raspberry pi / linux

    I am also assuming that I have missed a configuration step for the unix/linux CR vs DOS's CR/LF problems you get with text files between the systems.

    Has anybody else found this problem and what changes in the configuration are needed to resolve this

    thanks

    hal
    tribe bbs

    --- Mystic BBS v1.12 A46 2020/08/26 (Raspberry Pi/32)
    * Origin: Tribe BBS (21:1/177)
  • From Al@21:4/106.1 to hal on Friday, February 19, 2021 07:58:20
    Re: Errors with syncTerm downloads and Mystic BBS
    By: hal to All on Fri Feb 19 2021 03:24 pm

    Access via netrunner works seamlessly and uploads and downloads work perfectly.

    However, I have also tried syncterm and found that when I download using zmodem I get the following error

    I have a user here having trouble with netrunner (his preferred client) and is also having errors with syncterm. I think he had some success with a pre 1.0 version on his windows xp.

    I can only suggest you try a newer syncterm. You can get it for windows and the source for linux from syncterm.bbsdev.net.

    I have good results with both syncterm and netrunner on my linux desktop. I am running the newest prealpha of netrunner and an upto date syncterm built from source recently.

    Ttyl :-),
    Al

    ... Captain, he's thinking about my breasts again! - Deanna Troy
    --- SBBSecho 3.13-Linux
    * Origin: The Rusty MailBox - Penticton, BC Canada (21:4/106.1)
  • From hal@21:1/177 to Al on Friday, February 19, 2021 17:36:08
    Just tried the version they compiled this morning (v1.1a from the synctyerm.bbsdev.net) and the error doesn't occur - the version I was using was the previous week (oddly it reported as v 1.2a) [from sourceforge]

    Also tried the latest windows installer version but Windows antivirus
    software flagged it as bad and wouldn't let me run it (probably just a
    windows confusion) ... both the zip and the binary from syncterm.bbsdev.net work fine

    thanks

    --- Mystic BBS v1.12 A46 2020/08/26 (Raspberry Pi/32)
    * Origin: Tribe BBS (21:1/177)
  • From Al@21:4/106.1 to hal on Friday, February 19, 2021 21:54:00
    hal wrote to Al <=-

    Just tried the version they compiled this morning (v1.1a from the synctyerm.bbsdev.net) and the error doesn't occur - the version I was using was the previous week (oddly it reported as v 1.2a) [from sourceforge]

    The 1.1a is likely an alpha from before the 1.1 release? The 1.2a is an
    alpha, current code not yet released.

    I have been up and down loading qwk packets without issue.

    I just tried uploading and downloading files from the filebase and had no success with syncterm. I had limited success with Netrunner.

    Also tried the latest windows installer version but Windows antivirus software flagged it as bad and wouldn't let me run it (probably just a windows confusion) ... both the zip and the binary from syncterm.bbsdev.net work fine

    It's a bit confusing but there are problems. I'll work on getting my
    syncterm in sync with sbbs and experiment and get some logs to the syncterm developers.


    Ttyl :-),
    Al

    ... Help! I've fallen and can't reach my beer!
    --- MultiMail/Linux v0.52
    * Origin: The Rusty MailBox - Penticton, BC Canada (21:4/106.1)
  • From Digital Man to hal on Sunday, February 21, 2021 19:51:13
    Re: Errors with syncTerm downloads and Mystic BBS
    By: hal to All on Fri Feb 19 2021 03:24 pm

    Hi all I have setup a small BBS and got it up and running.


    Access via netrunner works seamlessly and uploads and downloads work perfectly.

    However, I have also tried syncterm and found that when I download using zmodem I get the following error

    !ERROR zmodem_recv_hex_error_init received Invalid Header not terminated with LF

    I assume this is because I am running this on a raspberry pi / linux

    I am also assuming that I have missed a configuration step for the unix/linux CR vs DOS's CR/LF problems you get with text files between the systems.

    Has anybody else found this problem and what changes in the configuration are needed to resolve this

    The problem you're describing was both recently introduce and fixed. So I would recommend using the v1.1 release of SyncTERM anyway, but if you do use the "latest and greatest" code from Git, you won't have that particular issue either (the v1.2alpha does have other issues however). So I recommend using v1.1 for now.
    --
    digital man

    This Is Spinal Tap quote #39:
    Female Airport Security Officer: Do you have any artificial plates or limbs? Norco, CA WX: 61.7°F, 21.0% humidity, 0 mph WSW wind, 0.00 inches rain/24hrs