• SSH Help

    From mrcrud@21:2/150 to All on Wednesday, October 27, 2021 09:48:06
    Hi...I'm setting up a BBS, and got Telnet access working with no problem. SSH is giving me problems. It fails with error message "Unable to set key (-2).

    I've tried everything I can think of: verified port is open, CryptLib is installed, server is configured correctly, tried changing ports, etc.

    Try it yourself, please. bbs.thecreepingcrud.com:1313 for telnet. That should work just fine. But bbs.thecreepingcrud.com:7777 (SSH) craps out.

    btw, my board is in the very beginning stages. So there's nothing to do right now, except get bored. :)

    Thanks!
    Gary

    ... Some people have one of those days. I have one of those lives.

    --- Mystic BBS v1.12 A47 2021/08/29 (Raspberry Pi/32)
    * Origin: 2o fOr beeRS bbs>>>20ForBeers.com:1337 (21:2/150)
  • From fang-castro@21:3/112 to mrcrud on Wednesday, October 27, 2021 11:48:23
    On 27 Oct 2021, mrcrud said the following...
    Hi...I'm setting up a BBS, and got Telnet access working with no
    problem. SSH is giving me problems. It fails with error message "Unable

    btw, my board is in the very beginning stages. So there's nothing to do right now, except get bored. :)

    looks like there's plenty for you to do! =p

    |08__ _ _ ____ |02_ _ |10___ _ _ |02____ |08_ _ _ ___
    |08| \| | |__\ |02|--| |10 | \/ |02|--| |08|__| |___ |

    --- Mystic BBS v1.12 A46 2020/08/26 (Linux/64)
    * Origin: ._.-. nightvault.fsxnet.nz port 2323 .-._. (21:3/112)
  • From MeaTLoTioN@21:1/158 to mrcrud on Thursday, October 28, 2021 16:19:19
    On 27 Oct 2021, mrcrud said the following...

    Hi...I'm setting up a BBS, and got Telnet access working with no
    problem. SSH is giving me problems. It fails with error message "Unable to set key (-2).

    run `netstat -tulpn|grep 7777` and see if something else has already bound to that port. Maybe you're trying to use a port that is already in use.

    I've tried everything I can think of: verified port is open, CryptLib is installed, server is configured correctly, tried changing ports, etc.

    Good luck, be interested to know how you get on.

    ---
    |14Best regards,
    |11Ch|03rist|11ia|15n |11a|03ka |11Me|03aTLoT|11io|15N

    |07── |08[|10eml|08] |15ml@erb.pw |07── |08[|10web|08] |15www.erb.pw |07───┐ |07── |08[|09fsx|08] |1521:1/158 |07── |08[|11tqw|08] |151337:1/101 |07┬──┘ |07── |08[|12rtn|08] |1580:774/81 |07─┬ |08[|14fdn|08] |152:250/5 |07───┘
    |07── |08[|10ark|08] |1510:104/2 |07─┘

    ... A SQL query walks into a bar and sees two tables. Asks: 'Can I join you?'

    --- Mystic BBS v1.12 A47 2021/08/10 (Linux/64)
    * Origin: thE qUAntUm wOrmhOlE, rAmsgAtE, uK. bbs.erb.pw (21:1/158)