• Access Requirement On Externals

    From DesotoFireflite@VALHALLA to All on Sunday, February 20, 2022 09:53:26
    I have noticed something strange going on the past weeks, that has changed. It seems if I have a program set for access requirements set to ANSI, the program is not showing up even if the user is set to ansi in the defaults. If I take the ANSI out of the access requirements, it shows up fine. I will use me as an example. In my Default Settings it reads:

    Terminal Mode: Auto CP437 / ANSI (color) (mouse)

    And I don't see any doors or programs that have an Access Requirement of ANSI.

    I even changed my Terminal Mode to:

    Terminal Mode: Auto CP437 /ANSI (color)

    with the same results. If I take out the Access Requiremnet of ANSI, all is fine and I can see the program. For now I have removed ANSI from the access requirements, so my users can play them, but I'm concerned what could be causing this. What module countrols this, so I can see if I don't have the latest one, or what could I have done since the latest update to cause this. Besides the ANSI string, it's not following others requirements I have set in other areas like PROT NOT HTTP, so thats why I asked if I missed a module update.

    SysOp: C.G. Learn, AKA: DesotoFireflite
    Valhalla Home Services! - (Synchronet) - bbs.valhallabbs.com
    Valhalla II! - (GAP) - bbs.valhallabbs.com:24
    Valhalla III! - (RemoteAccess) - bbs.valhallabbs.com:5023
    Valhalla IIII! - (Dungeons & Dragons BBS) - bbs.valhallabbs.com:26
    Valhalla Home Services Web! - http://bbs.valhallabbs.com
    A Gamers Paradise - Over 150 Registered Online Game Doors!
    Home Of Odin's Maze Game Server!

    --- Don't eat the yellow snow!
    ■ Synchronet ■ Valhalla Home Services ■ USA ■ http://valhalla.synchro.net
  • From Digital Man to DesotoFireflite on Sunday, February 20, 2022 11:57:54
    Re: Access Requirement On Externals
    By: DesotoFireflite to All on Sun Feb 20 2022 09:53 am

    I have noticed something strange going on the past weeks, that has changed. It seems if I have a program set for access requirements set to ANSI, the program is not showing up even if the user is set to ansi in the defaults. If I take the ANSI out of the access requirements, it shows up fine. I will use me as an example. In my Default Settings it reads:

    Terminal Mode: Auto CP437 / ANSI (color) (mouse)

    And I don't see any doors or programs that have an Access Requirement of ANSI.

    This sounds like a problem that was introduced recently (after v3.19b was release) and fixed on Feb-6:
    http://git.synchro.net/gitpushlog.ssjs#f5fed0b229e70b79a5ebb330af98a348ccbbfd6

    with the same results. If I take out the Access Requiremnet of ANSI, all is fine and I can see the program. For now I have removed ANSI from the access requirements, so my users can play them, but I'm concerned what could be causing this. What module countrols this, so I can see if I don't have the latest one, or what could I have done since the latest update to cause this.

    It's Synchronet itself (e.g. sbbs.dll for Windows).
    --
    digital man (rob)

    Breaking Bad quote #18:
    Already, Operation: TBD, thanks for nothing Gomey. - Hank Schrader
    Norco, CA WX: 64.7°F, 48.0% humidity, 4 mph SSE wind, 0.00 inches rain/24hrs
  • From DesotoFireflite@VALHALLA to Digital Man on Sunday, February 20, 2022 16:33:59
    Re: Access Requirement On Externals
    By: Digital Man to DesotoFireflite on Sun Feb 20 2022 11:57 am

    Re: Access Requirement On Externals
    By: DesotoFireflite to All on Sun Feb 20 2022 09:53 am

    I have noticed something strange going on the past weeks, that has
    changed. It seems if I have a program set for access requirements set
    to ANSI, the program is not showing up even if the user is set to ansi
    in the defaults. If I take the ANSI out of the access requirements, it
    shows up fine. I will use me as an example. In my Default Settings it
    reads:

    Terminal Mode: Auto CP437 / ANSI (color) (mouse)

    And I don't see any doors or programs that have an Access Requirement
    of
    ANSI.

    This sounds like a problem that was introduced recently (after v3.19b was release) and fixed on Feb-6: http://git.synchro.net/gitpushlog.ssjs#f5fed0b229e70b79a5ebb330af98a348ccb bfd6

    with the same results. If I take out the Access Requiremnet of ANSI,
    all is fine and I can see the program. For now I have removed ANSI
    from the access requirements, so my users can play them, but I'm
    concerned what could be causing this. What module countrols this, so I
    can see if I don't have the latest one, or what could I have done
    since the latest update to cause this.

    It's Synchronet itself (e.g. sbbs.dll for Windows).

    I checked, and I have the one from 2/1/22 in there, and thats the last update I did. This is crazy man, all these issues. I'm litterly at the point of doing a fresh install, but I'm putting that off as a last resort. I downloaded last nights sbbs_run.zip, and sbbs_dev.zip, but I kept getting a Xaccesserror when starting the control panel, so I went back to the 2/1/22 that build that I saved. I'll wait till tomorrow and get a later build incase last nights is corrupt.

    SysOp: C.G. Learn, AKA: DesotoFireflite
    Valhalla Home Services! - (Synchronet) - bbs.valhallabbs.com
    Valhalla II! - (GAP) - bbs.valhallabbs.com:24
    Valhalla III! - (RemoteAccess) - bbs.valhallabbs.com:5023
    Valhalla IIII! - (Dungeons & Dragons BBS) - bbs.valhallabbs.com:26
    Valhalla Home Services Web! - http://bbs.valhallabbs.com
    A Gamers Paradise - Over 150 Registered Online Game Doors!
    Home Of Odin's Maze Game Server!

    --- CAT (n.), Furry keyboard cover.
    ■ Synchronet ■ Valhalla Home Services ■ USA ■ http://valhalla.synchro.net
  • From Digital Man to DesotoFireflite on Sunday, February 20, 2022 15:11:19
    Re: Access Requirement On Externals
    By: DesotoFireflite to Digital Man on Sun Feb 20 2022 04:33 pm

    I checked, and I have the one from 2/1/22 in there, and thats the last update I did. This is crazy man, all these issues.

    This is unrelated to any other issues you've had or reported.

    I'm litterly at the point
    of doing a fresh install, but I'm putting that off as a last resort.

    Yeah, don't do that.

    I
    downloaded last nights sbbs_run.zip, and sbbs_dev.zip, but I kept getting a Xaccesserror when starting the control panel, so I went back to the 2/1/22 that build that I saved. I'll wait till tomorrow and get a later build incase last nights is corrupt.

    Okay, let us know.
    --
    digital man (rob)

    Synchronet "Real Fact" #43:
    Synchronet added Baja/PCMS support with v2.00a (1994)
    Norco, CA WX: 66.2°F, 52.0% humidity, 9 mph SSE wind, 0.00 inches rain/24hrs
  • From DesotoFireflite@VALHALLA to Digital Man on Monday, February 21, 2022 15:27:07
    Re: Access Requirement On Externals
    By: Digital Man to DesotoFireflite on Sun Feb 20 2022 11:57 am

    Re: Access Requirement On Externals
    By: DesotoFireflite to All on Sun Feb 20 2022 09:53 am

    I have noticed something strange going on the past weeks, that has
    changed. It seems if I have a program set for access requirements set
    to ANSI, the program is not showing up even if the user is set to ansi
    in the defaults. If I take the ANSI out of the access requirements, it
    shows up fine. I will use me as an example. In my Default Settings it
    reads:

    Terminal Mode: Auto CP437 / ANSI (color) (mouse)

    And I don't see any doors or programs that have an Access Requirement
    of
    ANSI.

    This sounds like a problem that was introduced recently (after v3.19b was release) and fixed on Feb-6: http://git.synchro.net/gitpushlog.ssjs#f5fed0b229e70b79a5ebb330af98a348ccb bfd6

    It's fixed now, Downloaded the latest build 2/21/22 this morning. Sorry, I didn't see this part yesterday cos I was frustrated and got ahead of myself.

    with the same results. If I take out the Access Requiremnet of ANSI,
    all is fine and I can see the program. For now I have removed ANSI
    from the access requirements, so my users can play them, but I'm
    concerned what could be causing this. What module countrols this, so I
    can see if I don't have the latest one, or what could I have done
    since the latest update to cause this.

    It's Synchronet itself (e.g. sbbs.dll for Windows).

    Thanks, like I said above, everything is fixed and running smooth. You are a good man Rob, you put up with a lot, and always seem to come through. Thanks to you and the Synchronet Team for providing first rate software.

    SysOp: C.G. Learn, AKA: DesotoFireflite
    Valhalla Home Services! - (Synchronet) - bbs.valhallabbs.com
    Valhalla II! - (GAP) - bbs.valhallabbs.com:24
    Valhalla III! - (RemoteAccess) - bbs.valhallabbs.com:5023
    Valhalla IIII! - (Dungeons & Dragons BBS) - bbs.valhallabbs.com:26
    Valhalla Home Services Web! - http://bbs.valhallabbs.com
    A Gamers Paradise - Over 150 Registered Online Game Doors!
    Home Of Odin's Maze Game Server!

    --- FART(n): An audio test of one's waste-disposal system.
    ■ Synchronet ■ Valhalla Home Services ■ USA ■ http://valhalla.synchro.net